Author Topic: 95 Mustang 3.8  (Read 4847 times)

wpack

  • Newbie
  • *
  • Posts: 7
  • Mustang: 98 Mustang GT
  • Location: Louisburg NC
95 Mustang 3.8
« on: November 19, 2009, 05:50:30 PM »
Got a question, went & warmed up the car on Tuesday, started fine, my mom went to get in the car, it had cut off & would not start, well I tried to start it today, it would catch, but would not stay running, sounded like it wasn't getting gas, any suggestions ?

Soaring

  • Global Moderator
  • *****
  • Posts: 4279
  • Gender: Male
  • 1965 Mustang coupe 289, '03 Mach1, 03 Lariat
  • Mustang: 1965 coupe 289, and 2003 Mach1
  • Daily driver: '03 Ford F-150 Lariat
  • Location: Wimberley, Texas
Re: 95 Mustang 3.8
« Reply #1 on: November 19, 2009, 06:38:18 PM »
Check the fuel flow by taking off the fuel filter and see if you have flow.  If not, then you may have a fuel pump that has gone south. 

wpack

  • Newbie
  • *
  • Posts: 7
  • Mustang: 98 Mustang GT
  • Location: Louisburg NC
Re: 95 Mustang 3.8
« Reply #2 on: November 21, 2009, 03:31:21 PM »
Soaring, where would the fuel filter be located ?

 

+-Navigation

Other languages
ESPANOL
FRANCAIS
Soaring
Soaring
In memory of our moderator Glen Wren AKA Soaring
1943-2011
Links



Dallas Mustang


Menu
LO-FI Version
Mustang classifieds
Muscle car classifieds
Classic Mustang FAQ


Mustangs for sale


Top Posters

Soaring
Posts: 4279
Thierry
Posts: 1379
66GTKFB
Posts: 845
rmodel65
Posts: 681
Jeff73Mach1
Posts: 471

Used Cars for sale - Ford Mustang classifieds - Forum Camaro FR

Powered by EzPortal