Author Topic: 2.3 fuel injectors not opening  (Read 4658 times)

holdover

  • Jr. Member
  • **
  • Posts: 28
  • Gender: Male
  • Mustang: 1965 289 4 speed FB, 1967 390 4 speed FB, 1992 Hatchback 302 5speed,2012 GT 6 speed
  • Location: Virginia
2.3 fuel injectors not opening
« on: May 24, 2010, 01:41:06 PM »
just put a 89 2.3 in a 93 that had a 2.3. Didn't have all the old '93 2.3 parts because the car was stripped of some parts including the relay box , which I purchased used and some of the sensor pulgs are different. When I tried to start it there is no fuel  coming out of the injectors, there is 50 lb +  pressure in the fuel rail. If I spray some fuel or ether into it, it runs. My question where does the injector get its impulse from? for some reason they they are not getting the signal to open.

thanks for any help

Soaring

  • Global Moderator
  • *****
  • Posts: 4279
  • Gender: Male
  • 1965 Mustang coupe 289, '03 Mach1, 03 Lariat
  • Mustang: 1965 coupe 289, and 2003 Mach1
  • Daily driver: '03 Ford F-150 Lariat
  • Location: Wimberley, Texas
Re: 2.3 fuel injectors not opening
« Reply #1 on: May 24, 2010, 02:28:34 PM »
Most likely the fuel rail isn't getting any gas.  You may just have a fuel pump issue.  Here's an article that may help understand the system.\
http://auto.howstuffworks.com/fuel-injection3.htm

holdover

  • Jr. Member
  • **
  • Posts: 28
  • Gender: Male
  • Mustang: 1965 289 4 speed FB, 1967 390 4 speed FB, 1992 Hatchback 302 5speed,2012 GT 6 speed
  • Location: Virginia
Re: 2.3 fuel injectors not opening
« Reply #2 on: May 24, 2010, 04:10:37 PM »
50+ lbs pressure  in the fuel rail with my guage, plenty of gas when I depress the valve when cranking. I'll read the article and see what I can work out

Thanks for the reply

holdover

  • Jr. Member
  • **
  • Posts: 28
  • Gender: Male
  • Mustang: 1965 289 4 speed FB, 1967 390 4 speed FB, 1992 Hatchback 302 5speed,2012 GT 6 speed
  • Location: Virginia
Re: 2.3 fuel injectors not opening, Need throtle body and sensors
« Reply #3 on: May 24, 2010, 06:50:43 PM »
read up on a couple of things, seems the throttle body sensors send a signal to the ecu and being that the 1989 TB will not connect to the '93 wiring, me thinks I need a TB and sensors that fit the 1993 wiring. Anyone got one? If it makes a difference it is a 5 speed car.


thanks

holdover

  • Jr. Member
  • **
  • Posts: 28
  • Gender: Male
  • Mustang: 1965 289 4 speed FB, 1967 390 4 speed FB, 1992 Hatchback 302 5speed,2012 GT 6 speed
  • Location: Virginia
Re: 2.3 fuel injectors not opening
« Reply #4 on: May 30, 2010, 09:24:04 PM »
OK here is the solution to the fuel injectors not pulsing. Tom on the All Fords forum enlightened me. The red lead on the injectors should have battery on it, whenever the ignition is in the on position. The pulse that activates the injector soleniod is a ground pulse, which opens the injector and allows fuel to enter the cylinder. Mine did not have battery due to some problem in the harness which i am locating, when I hot wired it the engine started and run fine.

rmodel65

  • Global Moderator
  • *****
  • Posts: 681
  • Gender: Male
  • the mustang man
  • Mustang: 65 fastback modded
  • Daily driver: 1991 gt vert
  • Location: US
Re: 2.3 fuel injectors not opening
« Reply #5 on: June 21, 2010, 12:15:53 PM »
i was gonna say check the distributor as the PIP might be bad but if youve played with the wiring its probably not that

 

+-Navigation

Other languages
ESPANOL
FRANCAIS
Soaring
Soaring
In memory of our moderator Glen Wren AKA Soaring
1943-2011
Links



Dallas Mustang


Menu
LO-FI Version
Mustang classifieds
Muscle car classifieds
Classic Mustang FAQ


Mustangs for sale


Top Posters

Soaring
Posts: 4279
Thierry
Posts: 1379
66GTKFB
Posts: 845
rmodel65
Posts: 681
Jeff73Mach1
Posts: 471

Used Cars for sale - Ford Mustang classifieds - Forum Camaro FR

Powered by EzPortal