Author Topic: 2.3 E-Brake Problem  (Read 2964 times)

MGallant6

  • Newbie
  • *
  • Posts: 1
  • Mustang: 1993 Mustang LX
  • Location: Calgary Alberta
2.3 E-Brake Problem
« on: August 26, 2009, 03:52:01 PM »
I was Pulling my E-Brake and it gave out and went all the way back, we found the cable that broke. The problem is the e-brake is still on and we can hear the brakes locked on... How do we release the e-brake?

Thanks

Soaring

  • Global Moderator
  • *****
  • Posts: 4279
  • Gender: Male
  • 1965 Mustang coupe 289, '03 Mach1, 03 Lariat
  • Mustang: 1965 coupe 289, and 2003 Mach1
  • Daily driver: '03 Ford F-150 Lariat
  • Location: Wimberley, Texas
Re: 2.3 E-Brake Problem
« Reply #1 on: August 26, 2009, 04:20:35 PM »
Take you rear hubs off and you will see where it connects to the braking system.   If you have disk brakes on the rear, study it carefully before detaching it. Just take it off there, and be careful how it is attached so that when you get your new cable, you can put it on correctly.  If you have a digital camera, take a picture of it before taking it off so you can visually see how it was attached. 

 

+-Navigation

Other languages
ESPANOL
FRANCAIS
Soaring
Soaring
In memory of our moderator Glen Wren AKA Soaring
1943-2011
Links



Dallas Mustang


Menu
LO-FI Version
Mustang classifieds
Muscle car classifieds
Classic Mustang FAQ


Mustangs for sale


Top Posters

Soaring
Posts: 4279
Thierry
Posts: 1379
66GTKFB
Posts: 845
rmodel65
Posts: 681
Jeff73Mach1
Posts: 471

Used Cars for sale - Ford Mustang classifieds - Forum Camaro FR

Powered by EzPortal