Author Topic: no power  (Read 1784 times)

davida

  • Newbie
  • *
  • Posts: 1
  • Gender: Male
  • Mustang: 98 4.6 gt
  • Daily driver: 96 mustang
  • Location: valdosta ga
no power
« on: September 10, 2010, 06:41:24 AM »
hi got a 98 gt mustang,with a 2000 4.6 motor,with approx 72k miles motor idles fine but when you put under load it has no power, motor lays down. i've replaced the fuel pump and filter, any ideas what i need to look for??

Soaring

  • Global Moderator
  • *****
  • Posts: 4279
  • Gender: Male
  • 1965 Mustang coupe 289, '03 Mach1, 03 Lariat
  • Mustang: 1965 coupe 289, and 2003 Mach1
  • Daily driver: '03 Ford F-150 Lariat
  • Location: Wimberley, Texas
Re: no power
« Reply #1 on: September 10, 2010, 01:41:11 PM »
Try cleaning your MAF so that you get an optimum air/fuel mixture.   And, while you are at it, replace the stock air filter with a K&N.   Welcome to the site.  Drag up a chair and stay awhile. 

97snakebite

  • Jr. Member
  • **
  • Posts: 15
  • Gender: Male
  • Mustang: 97 Cobra
  • Location: Sacramento, CA
Re: no power
« Reply #2 on: November 02, 2010, 03:19:01 PM »
if it was a maf his idle would be bad also...duh... try your TPS if not that check all your plugs and wires..most likely it will be a bad plug or wire

ted91

  • Newbie
  • *
  • Posts: 2
  • Gender: Male
  • Mustang: 04
  • Location: leeds
Re: no power
« Reply #3 on: November 10, 2010, 06:40:37 AM »
Sounds like a wire problem to me.

 

+-Navigation

Other languages
ESPANOL
FRANCAIS
Soaring
Soaring
In memory of our moderator Glen Wren AKA Soaring
1943-2011
Links



Dallas Mustang


Menu
LO-FI Version
Mustang classifieds
Muscle car classifieds
Classic Mustang FAQ


Mustangs for sale


Top Posters

Soaring
Posts: 4279
Thierry
Posts: 1379
66GTKFB
Posts: 845
rmodel65
Posts: 681
Jeff73Mach1
Posts: 471

Used Cars for sale - Ford Mustang classifieds - Forum Camaro FR

Powered by EzPortal