Author Topic: Missing  (Read 1249 times)

blueagle

  • Newbie
  • *
  • Posts: 3
  • Gender: Male
  • Mustang: 1995 mustang
  • Location: Las Vegas, NV
Missing
« on: February 26, 2010, 09:58:01 PM »
I have a 1995 Ford Mustang. Check engine light came on and gave CO1 and CO5. replaced everything. Finally took it and had the transmission rebuilt. Check engine light is gone but now I get 100 miles per tank and it misses when driving and I have noticed that I can go 35 mph without touching gas pedal. Can anyone give me any suggestions on what the problem could be?

Soaring

  • Global Moderator
  • *****
  • Posts: 4279
  • Gender: Male
  • 1965 Mustang coupe 289, '03 Mach1, 03 Lariat
  • Mustang: 1965 coupe 289, and 2003 Mach1
  • Daily driver: '03 Ford F-150 Lariat
  • Location: Wimberley, Texas
Re: Missing
« Reply #1 on: February 27, 2010, 12:57:11 AM »
Try cleaning the MAF sensor.  I can go 35 MPH easily without touching the gas pedal in my 03 F-150 that has a 4.6 L engine and automatic tranny.  That's not unusual if you are coasting down from a higher speed.    After you clean the MAF, and it still misses, then you need a general tune-up.  That includes plugs and wires plus setting the timing to correct specs.  Check the codes again to see what may be the problem. 

Mach1EH

  • Photo contest winner
  • *
  • Posts: 61
  • Gender: Male
    • Assorted pictures of my Mustangs, trips and truck.
  • Mustang: 2003 Mach1 & 2011 GT/CS vert
  • Daily driver: 2006 F150 FX4
  • Location: Quinte West, Ontario Canada - near Trenton
Re: Missing
« Reply #2 on: March 01, 2010, 08:40:31 AM »
errr...

Was it ever brought into a Toyota dealership for servicing?  (j/k  ;D)

Check the throttle body for any *gunk* .

my $0.02

Soaring

  • Global Moderator
  • *****
  • Posts: 4279
  • Gender: Male
  • 1965 Mustang coupe 289, '03 Mach1, 03 Lariat
  • Mustang: 1965 coupe 289, and 2003 Mach1
  • Daily driver: '03 Ford F-150 Lariat
  • Location: Wimberley, Texas
Re: Missing
« Reply #3 on: March 01, 2010, 07:27:56 PM »
Again, check the codes.  It may be just a coil gone bad. 

blueagle

  • Newbie
  • *
  • Posts: 3
  • Gender: Male
  • Mustang: 1995 mustang
  • Location: Las Vegas, NV
Re: Missing
« Reply #4 on: March 02, 2010, 05:06:24 PM »
I have changed the spark plugs, spark plug wires, fuel pump and transmission. The car is running rough and the mechanic mentioned a ditributor behing the manifold that maybe bent and not firing correctly. I have looked thru the repair manuel and can not find what he could be referring too. He tells me it costs $180 plus $110 for labor so I am kind of leary. AS FOR MAINTAINING 35 MPH it stays there for miles and the road is flat. I know going 65 and taking foot off accellerator that the car will continue to go 35 mph. So can I please get better advice?

 

+-Navigation

Other languages
ESPANOL
FRANCAIS
Soaring
Soaring
In memory of our moderator Glen Wren AKA Soaring
1943-2011
Links



Dallas Mustang


Menu
LO-FI Version
Mustang classifieds
Muscle car classifieds
Classic Mustang FAQ


Mustangs for sale


Top Posters

Soaring
Posts: 4279
Thierry
Posts: 1379
66GTKFB
Posts: 845
rmodel65
Posts: 681
Jeff73Mach1
Posts: 471

Used Cars for sale - Ford Mustang classifieds - Forum Camaro FR

Powered by EzPortal