Author Topic: Engine is running like crap, after spraying it off.  (Read 4665 times)

built2kill

  • Newbie
  • *
  • Posts: 2
  • Mustang: 1999 Mustang GT 4.6
  • Daily driver: 2008 Dodge Charger RT Custom
  • Location: Kentucky
Engine is running like crap, after spraying it off.
« on: July 14, 2009, 09:26:39 PM »
Hey all, I always washed all my engines off at the car wash and I did it again today with my 99 GT 4.6 for the first time and the check engine light came on for a second and went off , the car now is running terrible. Will this go away after the engine drys off? Do I need to set the ECM by disconnecting the battery? Or is it a shorted out sensor that is going to have to be replaced? I would appreciate any assistance as I am a new member. I have had two other Stangs with no problem when engine was washed.

Thanks,  Rob

Soaring

  • Global Moderator
  • *****
  • Posts: 4279
  • Gender: Male
  • 1965 Mustang coupe 289, '03 Mach1, 03 Lariat
  • Mustang: 1965 coupe 289, and 2003 Mach1
  • Daily driver: '03 Ford F-150 Lariat
  • Location: Wimberley, Texas
Re: Engine is running like crap, after spraying it off.
« Reply #1 on: July 15, 2009, 02:51:36 AM »
Give it a few days to dry up, then unhook the battery and plug it back in if she doesn't clear up. 

jethat

  • Sr. Member
  • ****
  • Posts: 163
Re: Engine is running like crap, after spraying it off.
« Reply #2 on: July 15, 2009, 07:44:42 AM »
Modular engines hate getting wet. If you have a compreassor with a blow out tool blow the top of the engine off try to get in the spark plug hole. Best to not wash them and if you do be careful not to soak the top of the engine.

Konrad

  • Global Moderator
  • *****
  • Posts: 220
  • Gender: Male
  • Mustang: 2007 GT 5 speed
  • Daily driver: that is my daily driver
  • Location: British Columbia
Re: Engine is running like crap, after spraying it off.
« Reply #3 on: July 15, 2009, 10:56:26 AM »
What is it about modular engines that makes them hate getting wet? The engine in my 2007 is different but is still considered a modular engine. Does it apply to mine as well?

1993GTJL

  • Newbie
  • *
  • Posts: 8
  • Gender: Male
  • Mustang: 1993 GT 5.0
  • Daily driver: Mazda 6 - 2006
  • Location: Aurora
Re: Engine is running like crap, after spraying it off.
« Reply #4 on: July 15, 2009, 10:16:14 PM »
I always try to be careful too when washing out the engine. I usually carry an couple extra grocery bags in the trunk to cver up the battery and any electrical components. It works well.

jethat

  • Sr. Member
  • ****
  • Posts: 163
Re: Engine is running like crap, after spraying it off.
« Reply #5 on: July 15, 2009, 11:14:59 PM »
What is it about modular engines that makes them hate getting wet? The engine in my 2007 is different but is still considered a modular engine. Does it apply to mine as well?
Yes yours is a modular. Mod motors spark plugs and coils are on the top of the engine the spark plugs are inside deep holes that can fill with water when the engine is washed. If theres any weak point in the waterproofing of the system you get a missfire. Sometime that water frys coils to. Best to refrain from washing the motor to much and be prepaird for headaches when you do..

Soaring

  • Global Moderator
  • *****
  • Posts: 4279
  • Gender: Male
  • 1965 Mustang coupe 289, '03 Mach1, 03 Lariat
  • Mustang: 1965 coupe 289, and 2003 Mach1
  • Daily driver: '03 Ford F-150 Lariat
  • Location: Wimberley, Texas
Re: Engine is running like crap, after spraying it off.
« Reply #6 on: July 16, 2009, 01:28:29 AM »
I haven't washed my 03 Mach1 engine.  It's pretty dusty, but not greasy or oily.  How do you guys keep these 4.6.s clean? 

Builtmachtough03

  • Newbie
  • *
  • Posts: 6
  • Gender: Female
  • Mustang: 2003 Mach1
  • Location: Aurora
Re: Engine is running like crap, after spraying it off.
« Reply #7 on: July 16, 2009, 08:45:21 PM »
i have cleaned the mach 1's engine i just cover up the battery, the alternator, and the fuse box, but then again i dont soak it i just lightly spray it then just clean it up with a wet rag. but i agree with jethat there a good chance water got down on the plugs and or coil and it caused a misfire which is why you got the check engine light.

FASTBACK65GT

  • Sr. Member
  • ****
  • Posts: 134
  • Gender: Male
  • I buy H.O. Slot Cars!
    • Phil's '65 Mustang GT
  • Mustang: 1965 Mustang Fastback GT
  • Daily driver: Ranger 4.0; 4.10; 4x4 is my daily driver.
  • Location: Fair Grove, MO
Re: Engine is running like crap, after spraying it off.
« Reply #8 on: July 18, 2009, 10:13:31 AM »
If you are using a local commercial power washer, I wash my engine in the "spot free" mode.  It is a lot less powerful spray making it less likely to cause problems.  Then, leave the hood up for as long as you can. :)

 

+-Navigation

Other languages
ESPANOL
FRANCAIS
Soaring
Soaring
In memory of our moderator Glen Wren AKA Soaring
1943-2011
Links



Dallas Mustang


Menu
LO-FI Version
Mustang classifieds
Muscle car classifieds
Classic Mustang FAQ


Mustangs for sale


Top Posters

Soaring
Posts: 4279
Thierry
Posts: 1379
66GTKFB
Posts: 845
rmodel65
Posts: 681
Jeff73Mach1
Posts: 471

Used Cars for sale - Ford Mustang classifieds - Forum Camaro FR

Powered by EzPortal