Author Topic: 99mustang shuts off after warm up. HELP  (Read 1338 times)


  • Newbie
  • *
  • Posts: 1
  • Gender: Male
  • Mustang: 1999
  • Location: arkansas
99mustang shuts off after warm up. HELP
« on: December 08, 2011, 07:22:17 PM »
Okay guys/ladies. My Mustang has been shutting off after it warms up. Symptoms: i go to start the car i can hear the pump and it starts right up. Soon as it starts the rpms drop and i have to push the gas. The rpms slowly rises up on its own(foot off gas) and it idles ok. Soon as i put it in drive it begins to give low rpms as if its a maf sensor or throttle position sensor. I know thats not it though cause the car shuts off after unplugging them. Before warm up if i floor it its like it slows the car down. No bucking or anything in that manner, it just simply wont go. Can get to 4th gear, but in 5th it slows down as well. After the car reaches its warm up temperature, it looses power and shuts off. And i have to wait for it to cool down completely.   What is wrong with my baby? I'm thinking fuel pump. But i can hear it and it starts with RIGHT up. I found that the o2 sensor(back right one ) was completely cut by the wires. Attached em back together. And nothing changes. HELP



Other languages
In memory of our moderator Glen Wren AKA Soaring

Dallas Mustang

LO-FI Version
Mustang classifieds
Muscle car classifieds
Classic Mustang FAQ

Mustangs for sale

Top Posters

Posts: 4279
Posts: 1379
Posts: 845
Posts: 681
Posts: 471

Used Cars for sale - Ford Mustang classifieds - Forum Camaro FR

Powered by EzPortal