Author Topic: Ametech Engine RESTORE Oil  (Read 3418 times)

trent86

  • Jr. Member
  • **
  • Posts: 12
  • Gender: Male
  • Mustang: 1965 Coupe
  • Daily driver: Jeep wrangler 2006
  • Location: UK
Ametech Engine RESTORE Oil
« on: September 19, 2010, 05:00:23 AM »
Hi,
I have a 65 289 Mustang with an oil light that seems to come on when first starts up (just flickers) once up to proper oil temp it stays on. This has only happened since I changed the oil (have since changed it again back to 2050) and the car does not lose oil or smoke or any untoward noises.
Does anyone have any thoughts about the advantages!! of using this Ametech stuff?

Soaring

  • Global Moderator
  • *****
  • Posts: 4279
  • Gender: Male
  • 1965 Mustang coupe 289, '03 Mach1, 03 Lariat
  • Mustang: 1965 coupe 289, and 2003 Mach1
  • Daily driver: '03 Ford F-150 Lariat
  • Location: Wimberley, Texas
Re: Ametech Engine RESTORE Oil
« Reply #1 on: September 19, 2010, 04:43:50 PM »
I've never used it.  I use Mobil 1 synthetic with a Motorcraft filter in my 289 and it runs like a scared rabbit with no oil light turning on.   You may have an oil pump going south. 

 

+-Navigation

Other languages
ESPANOL
FRANCAIS
Soaring
Soaring
In memory of our moderator Glen Wren AKA Soaring
1943-2011
Links



Dallas Mustang


Menu
LO-FI Version
Mustang classifieds
Muscle car classifieds
Classic Mustang FAQ


Mustangs for sale


Top Posters

Soaring
Posts: 4279
Thierry
Posts: 1379
66GTKFB
Posts: 845
rmodel65
Posts: 681
Jeff73Mach1
Posts: 471

Used Cars for sale - Ford Mustang classifieds - Forum Camaro FR

Powered by EzPortal