Author Topic: Kick-down not working C4 auto  (Read 16871 times)

Peranaman

  • Newbie
  • *
  • Posts: 3
Kick-down not working C4 auto
« on: April 05, 2005, 06:13:52 PM »
Hi,

I have a Ford Capri Mk 1 - Perana - 1971.  It has the Mustang 302 engine and a C4 Autobox.

The kick down does not appear to work. There is a vacuum pipe leading from the Edelbrock intlet manifold down to the gearbox but I have no kick-down linkage on the new Holley 570 Street Avenger carb.

Any ideas how I check to get the kick-down working?

thanks  Chris  UK

racedraper

  • Sr. Member
  • ****
  • Posts: 304
Re: Kick-down not working C4 auto
« Reply #1 on: May 17, 2005, 09:12:56 PM »
correct if im not wrong , but you might have to get a linkage adaptor.I know I had to get one when I got my 600cfm edelbrock carb.But the only way I know to check one is to have someone sit in the car and stomp on the throttle to set if the linkage when down shift . All else false just switch to a 5 speed.lol

Ken Moore

  • Jr. Member
  • **
  • Posts: 33
Re: Kick-down not working C4 auto
« Reply #2 on: May 19, 2005, 01:01:29 PM »
My 66 Mustang has 289 w/c4. the vacume line goes to the modulating valve. The kick down is acomplished by the throttle linkage, there's an arm that is attached to the linkage and drops down to align with the lever on the trans. the two are connected with a cable. You may have to rig up something like that.

 

+-Navigation

Other languages
ESPANOL
FRANCAIS
Soaring
Soaring
In memory of our moderator Glen Wren AKA Soaring
1943-2011
Links



Dallas Mustang


Menu
LO-FI Version
Mustang classifieds
Muscle car classifieds
Classic Mustang FAQ


Mustangs for sale


Top Posters

Soaring
Posts: 4279
Thierry
Posts: 1379
66GTKFB
Posts: 845
rmodel65
Posts: 681
Jeff73Mach1
Posts: 471

Used Cars for sale - Ford Mustang classifieds - Forum Camaro FR

Powered by EzPortal