Author Topic: Instrument cluster lights help  (Read 2601 times)

sarge102

  • Jr. Member
  • **
  • Posts: 10
  • Gender: Male
  • Mustang: 1967 Coupe
  • Location: Shreveport, LA
Instrument cluster lights help
« on: June 02, 2014, 07:34:21 PM »
I have a 67 coupe that I am trying to replace the dash. I am unable to find out what is the problem with the instrument cluster lights, I have none. I have checked the fuse block but am not sure which is the correct fuse. The fuse block has one horizontal fuse, three vertical fuses and another horizontal on the bottom. I appears as though the center vertical fuse has no power, could this be the instrument cluster fuse? Any help would be appreciated.

Topless_Horse

  • Sr. Member
  • ****
  • Posts: 132
  • Gender: Male
  • Mustang: 66 convertible
  • Daily driver: Ram 2500 Cummins
  • Location: South Dakota
Re: Instrument cluster lights help
« Reply #1 on: June 03, 2014, 07:04:49 AM »
The instrument lights fuse is the center vertical fuse (2.5 A) in the panel.  Also be certain that the light switch knob is rotated fully clockwise to put the dash lights at their maximum brightness.

sarge102

  • Jr. Member
  • **
  • Posts: 10
  • Gender: Male
  • Mustang: 1967 Coupe
  • Location: Shreveport, LA
Re: Instrument cluster lights help
« Reply #2 on: June 12, 2014, 08:08:27 PM »
Thank you for the response. Unfortunatly that is what I was afraid of. That fuse has no power, maybe you could be of more assistance. I have been looking at the wiring diagram and have not found the answer. From what I can tell, it would appear as though a blue with red stripe wire runs from the light switch to the fuse. I believe the circuit runs from the ignition to the light switch to the fuse. I do not have any power at the light switch on the blue wire either. Any suggestions?

Topless_Horse

  • Sr. Member
  • ****
  • Posts: 132
  • Gender: Male
  • Mustang: 66 convertible
  • Daily driver: Ram 2500 Cummins
  • Location: South Dakota
Re: Instrument cluster lights help
« Reply #3 on: June 13, 2014, 06:45:03 AM »
I'll try but my 67 schematic is not very good.  The blue/red does come from the light switch and goes through the fuse to provide power to the dash lights.  The light switch is powered from battery (always hot) through a black/orange wire that is spliced to the black/yellow wire that comes from the engine compartment.   Inside the light switch the power from the black/orange wire goes to a resistor coil that is attached to the light switch shaft.  The other side of this coil is attached to the blue/red wire.

The blue/red wire and "inst ltg" fuse will have no power if the light switch knob is turned fully counterclockwise [added edit - or if the knob is not pulled out at least to the "parking light" position].  That knob serves as the dimmer for those lamps.  To get full brightness the light switch knob needs to be turned fully clockwise (the knob has to be pulled out to at least the parking light position too).

I would check to confirm that the knob of your light switch is turned fully clockwise.  If it is and you still have no dash light power, then check the black/orange wire to verify it has power at the light switch.  If it does, I would suspect either a mis-mated connector on the light switch or an internal failure of the light switch.

sarge102

  • Jr. Member
  • **
  • Posts: 10
  • Gender: Male
  • Mustang: 1967 Coupe
  • Location: Shreveport, LA
Re: Instrument cluster lights help
« Reply #4 on: June 14, 2014, 04:47:36 PM »
Once again, thank you for your assistance. I have another question however. I have checked the power lead and it is hot, however still no power to the dash. I decided to check the switch, which is a new one from mustangs unlimited. If I understand things correctly, with the switch in the on position there should be no resistance between the power terminal and the dash terminal, correct? There is none between the power and the headlight terminal, its as if the terminals are not connected in the switch.

Topless_Horse

  • Sr. Member
  • ****
  • Posts: 132
  • Gender: Male
  • Mustang: 66 convertible
  • Daily driver: Ram 2500 Cummins
  • Location: South Dakota
Re: Instrument cluster lights help
« Reply #5 on: June 15, 2014, 07:54:10 AM »
Yes, you are correct, there should be no resistance between the power terminal and the dash terminal with the switch pulled out and rotated fully clockwise (there should be a soft "click" you feel - that will be max brightness).  It sounds like your switch might be bad.

There is a wiper that connects the switch shaft-mounted resistor to the switch body.  If it's not properly aligned and not making contact, you won't get power to the dash lights.   I've attached a couple photos in the hope that they will help you a little.

sarge102

  • Jr. Member
  • **
  • Posts: 10
  • Gender: Male
  • Mustang: 1967 Coupe
  • Location: Shreveport, LA
Re: Instrument cluster lights help
« Reply #6 on: July 08, 2014, 07:03:47 PM »
Topless,

     Thank you for your help, with that I have been able to solve the problem. Much appreciated.

 

+-Navigation

Other languages
ESPANOL
FRANCAIS
Soaring
Soaring
In memory of our moderator Glen Wren AKA Soaring
1943-2011
Links



Dallas Mustang


Menu
LO-FI Version
Mustang classifieds
Muscle car classifieds
Classic Mustang FAQ


Mustangs for sale


Top Posters

Soaring
Posts: 4279
Thierry
Posts: 1379
66GTKFB
Posts: 845
rmodel65
Posts: 681
Jeff73Mach1
Posts: 471

Used Cars for sale - Ford Mustang classifieds - Forum Camaro FR

Powered by EzPortal