Author Topic: I'm New and I need help!!!  (Read 2561 times)

Malibutommy

  • Newbie
  • *
  • Posts: 1
I'm New and I need help!!!
« on: June 15, 2008, 08:14:24 PM »
Hey Everybody. Let me catch everyone up to speed. My engine went boom in my 1989 F-150 4x4 5.0 5-speed. I just rebuilt a 302 out of a 1980 F-150 for it. I put in a slightly bigger cam (204/214 @ .50, 0.448/0.472) and since I did that, I switched to a MAF setup out of a 1991 Mustang GT 5.0 because I had heard that the bank injection setup wouldn't work with the cam. I installed the timing gears that you can put on 2 degrees advanced or retarded and put it at advanced because someone on here told me that they did it and are pleased with the performance and gas mileage associated with it. I also bolted on Dynomax long tube headers and eliminated the EGR and Smogpump, but I haven't gotten the EGR position simulator yet. I have everything in the truck and all wired up the way its supposed to be (I hope). The injectors are wired up for the truck firing order and the plug wires are on for the truck firing order also (not the HO firing order).

Well I fired it up the other day and had it running well enough to break in the new cam but It wouldn't idle for crap and kept stalling out. So I kept trying to get it timed right and adjusted the idle screw a little because I figured it might want a little more with the advancement on the timing gears and the still couldn't get it to idle. It runs ok at higher RPMs but won't idle no matter what I do. I tried to pull KOEO codes and the "engine" light wouldn't flash so I had to try to read them off of my digital multimeter. the best I could come up with (I did it like 4 times to be sure) was 31 (EGR-expected) 67 (Neutral safety switch malfunction- Clutch position switch operating just as it should) and 85 (Canister purge solenoid circuit failure- wouldn't cause it not to run right). I checked the TPS and it is at 1.0 volts at closed and 4.4 volts at Wide-open and is getting 7.5 voltage from Computer. I checked the IAC and it is getting 12 volts and the ohmic resistance is at 12 ohms (within range) so I removed and cleaned it (it is newer and was squeaky clean). I checked the Fuel Pressure and it is at 40 psi (acceptable is 30-45 psi) but I removed the vacuum hose from the regulator and the pressure didn't change like it should. But then I ran out of light and had to come inside so I couldn't do the regulator test in the Haynes.

I went out there today and I could get it to run if I held my hand partially over the MAF blocking the airflow (with cone filter removed) and it would idle ok but that is usually indicative of a vacuum leak and I can't find one if my life depended on it. It also will idle ok if I spray carb cleaner into the intake tube which tells me I might have a fuel problem, but the pressure is good and the lowest it drops at 3000 RPM is 30 psi which is still within specs. I am a mechanic so you can be as technical in your answers as you would like to be.

So all I have is a possible fuel pressure regulator or mystery vacuum leak... I probably forgot some stuff seeing as how I have been trying to get it to run right for a couple days now. I need help!!! Any suggestions would be greatly appreciated. Thank You in advance.

 

+-Navigation

Other languages
ESPANOL
FRANCAIS
Soaring
Soaring
In memory of our moderator Glen Wren AKA Soaring
1943-2011
Links



Dallas Mustang


Menu
LO-FI Version
Mustang classifieds
Muscle car classifieds
Classic Mustang FAQ


Mustangs for sale


Top Posters

Soaring
Posts: 4279
Thierry
Posts: 1379
66GTKFB
Posts: 845
rmodel65
Posts: 681
Jeff73Mach1
Posts: 471

Used Cars for sale - Ford Mustang classifieds - Forum Camaro FR

Powered by EzPortal